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1 Introduction

When producing Microsoft Word documents for M269 eTMAs there are several word processing questions
to answer:

e How do | insert any of the almost 40 mathematical symbols into my document ?

e What font should | use so that a tutor or student receiving my work or marking will be able to see
all the symbols as | intended ?

e If I receive a document where font substitution has taken place and mangled the intended characters,
how do | find out what the original characters were ?
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This note addresses these questions for M269 students and staff producing and marking eTMAs in Mi-
crosoft Word:

1. It provides Microsoft Word templates that give toolbars and keystroke shortcuts to insert the math-
ematical characters for M269 which are not on the keyboard. For tutors there are also templates
which give toolbars and keystroke shortcuts for some marking tasks.

2. The note provides instructions for creating or editing the templates to add any other items you want
to the the toolbars or keyboard shortcuts.

3. The note ends with a section on the fonts you should use so that tutors and students do not get
problems with font substitution and missing fonts

2 For Those in a Hurry

Microsoft Word Templates in the same place as you found this file, there should also be:
e M269MolyneuxWordTemplate2013Stu.dot
e M269MolyneuxWordTemplate2013Stu.dotx
e M269MolyneuxWordTemplate2013Tut.dot
e M269MolyneuxWordTemplate2013Tut.dotx
e M269MolyneuxWordTemplate2013Mon.dot
e M269MolyneuxWordTemplate2013Mon.dotx

The templates with file extensions .dot are compatible with Word 97-2004 format, while those
ending in .dotx are in the XML based format for later versions of Word. None of the templates
contain macros (at least none written by me). This note assumes that you have made file extensions
visible (see section A.1)

The files with names ending in Stu are aimed at students, while those ending with Tut and Mon have
some extra features for marking and are aimed at tutors and monitors.

Choose one and place it somewhere where Word can find it — this will probably be your Microsoft
User Templates folder — if you do not know where this is then see section 3.1 below. Copy the
autotext and styles to your Normal.dotm and for existing Word files, copy the styles into them.

Font Recommendations — use the font Arial Unicode MS for any mathematical operators you use in
your documents you are sending to other people. DejaVu fonts are available for all platforms from
http://dejavu-fonts.org and have most of the mathematical operators as well as fonts suitable
for the text. Lucida Sans Unicode is the M269 recommendation and is available for both PC and Mac
for recent versions of operating system and Word but lacks some of the symbols | use — such as
the (red) ticks ¢ and crosses X

Missing Fonts — if you see odd boxes (O0) or unexpected symbols then it may be that you have some
missing fonts and font substitution has taken place. To get the Font Substitution dialog box:

Word 2010 for Windows — in the File tab, click Options, then Advanced, scroll to the Show Docu-
ment Content options and click the Font Substitutions button.

Word 2011 for Mac — from Word menu — Preferences. .. item — Compatibility item and click Font
Substitution. ..

See section 5 for more details and notes for other versions of Word.

3 Word Templates

The Word templates with names ending in Stu provide the toolbar shown in figure 1, while the templates
with names ending in Tut are shown in figure 2 (The interface for the templates ending in Mon are similar
to those for Tut)


.dot
.dotx
http://dejavu-fonts.org
Stu
Tut
Tut
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Figure 1: Toolbar from Template ending Stu
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Figure 2: Toolbar from Template ending Tut

The toolbar from template 207 3Stu has all the mathematical characters not on the keyboard plus the not
a functional dependency (+-) symbol which is formed by placing two characters on top of each other. The
toolbar from templates 2013Tut and 2013Mon provide a superset of the features of the previous toolbar.
Along with the math symbols, they provide buttons (and keystroke shortcuts) to produce ticks, crosses,
add comments, toggle track changes, zoom, a marking submenu that has a highlighted style for block or
inline (code or ordinary text) marking comments and also a submenu of further symbols. The autotext in
the templates uses Lucida Sans Unicode

CodeBlock gzg:g:’:k
CodeRun MarkingBlock
MarkingBlock MarkingCodeBlock
MarkingCodeBlock MarkingRun
MarkingRun MarkingStrikeOut
MarkingStrikeOut MarkingCodeRun
. Normal
CodeBlock MarkingCodeRun Default Inline
CodeRun Normal MarkingComment
Normal Default Inline MonitorRun
Default Inline MarkingComment MonitorBlock

MonitorComment

~

> 2Dt

TR

Figure 3: Menus from the Templates

3.1 Installing the Word Templates

The installation varies slightly depending on your choice of template and version of Word.

1. Place a copy of the template in your User Templates folder. (see section A.3)
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2. Open the template in Word — you have to do this by going File > Open... — if you double-click on
the template it will open a new Word document based on the template not open the template file
itself.

3. Now navigate to the Organizer dialog box (see 4)

M269MolyneuxWordTemplate2013Stu — copy the autotext from the template to your Normal.dotm
— the autotext entries all start with mx. Also copy the styles CodeBlock, CodeRun.

M269MolyneuxWordTemplate2013Tut — copy the autotext from the template to your Normal.dotm
— the autotext entries all start with mx. Also copy the styles CodeBlock, CodeRun, Marking-
Block, MarkingCodeBlock, MarkingRun, MarkingStrikeOut and MarkingCodeRun to your Nor-
mal.dotm (global template).

M269MolyneuxWordTemplate2013Mon — as for the Tut templates but also copy the styles Moni-
torBlock, MonitorRun, and the autotext mxmonitor: to your Normal.dotm (global template).

You will only have to do this once (Normal will retain the autotext and styles)

4. The steps in getting the Organizer dialog box depend on your version of Word (and there are many
alternative ways in each version of Word)

Toolbar — click on the item towards the right of the toolbar (this works for me in Word 2011 but |
haven’t tested it elsewhere)

Word 2011 Go [Format>> Style. .. >> Organizer. .. }

Word 2010 We need to use both the Organizer (to copy the styles) and the Building Blocks Orga-
nizer (to copy the autotext) (Murray, 2010, pages 123,231)

e Go Developer tab > Templates group, click Document Template. In the Templates and Add-
ins dialog box, click Organizer. ..
{Developer>> Templates>> Document Template>> Organizer. .. }

e For the Building Blocks Organizer, go Insert tab > Text group > Building Blocks Organizer
[Insert>> Text>> Building Blocks Organizer}

5. You can now open a new Word session, navigate to the Templates and Add-ins dialog box and load
the template (see section A.4). The marking styles will be available in new documents based on
Normal.dotm (or .dot) — however they will not be available in existing documents or documents
from third parties without an extra step — see 6 below.

6. For existing or third party documents, if you are using M269MolyneuxWordTemplate2013Tut.dotm
you have to copy the marking styles into the document using the Organizer dialog — copy them
from Normal.dotm (or the original template M269MolyneuxWordTemplate2013Tut.dotm but that
will require opening that file and if you have already copied them to Normal.dotm then it will be
quicker).

Explanation

If you haven’t played around with templates, styles, autotext, toolbars and macros before then some of
the above instructions may appear a bit mysterious (they still appear convoluted to me). Here is a brief
description of what happens when you open a Word document:

New document inherits styles, autotext, toolbars, menu items, macros from the attached template (usu-
ally Normal.dotm). Any loaded global template provides further toolbars, menu customisation and
macros.

Existing document does not inherit styles from the attached template (though it may have obtained the
styles it uses from that template when created). The autotext in the attached template can be used
though. Any loaded global template provides further toolbars, menu customisation and macros.

For more detail on this, see Microsoft note Word Document Templates vs. Word Add-ins (Global Templates)
athttp://msdn.microsoft.com/en-us/1library/aal41685(v=office.10).aspx and Shauna Kelly on
Sending Word Documents at http://www.shaunakelly.com/word/sharing/wilTmyformatchange.html

If you have noticed the button labeled Automatically update document styles in the Templates and Add-ins
dialog, do not be tempted to check it. If you received a third party document which was based on that


http://msdn.microsoft.com/en-us/library/aa141685(v=office.10).aspx
http://www.shaunakelly.com/word/sharing/willmyformatchange.html
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user’s Normal.dotm then you would clobber any document styles with the same names as styles in your
Normal.dotm and if the third party had edited those styles then some formatting would be altered — read
the Shauna Kelly article mentioned above for the full details.

Further Customisation Notes

Making Word Open Documents in a Certain View http://word.mvps.org/faqs/general/SaveViewAndZoom.
htm

3.2 Shortcut Keys

For a more complete list of keyboard shortcuts see:

Word for Mac http://office.microsoft.com/en-gb/mac-word-help/word-keyboard-shortcuts-
HA102929541.aspx

Word for Windows http://support.microsoft.com/kb/290938

To list all Word commands and keyboard shortcuts in Word 2011 for Mac, go Tools menu, Macro menu,
click Macros... to get the Macros dialog. In the Macros in: pop-up menu, click Word commands
and then in Macro name: box, type ListCommands, click Run and in the resulting dialog box choose
Create a new document which lists: with either Current menu and keyboard settings or All Word
commands

To Clear Character and Paragraph Direct Styles see http://support.microsoft.com/kb/123302, http:
//office-watch.com/t/n.aspx?a=1552 and use the shortcuts for the Reset Char and Reset Para
commands.

ResetChar Makes the selection the default character format of the applied style
ResetPara Makes the selection the default paragraph format of the applied style
Notes on the following table:

Styles color coding

o Stu: ,
e Tut: +,

Health Warning there may be some conflicts with other shortcut keys — you may want to change

some. In particular, the _v/_ and _X_ actions are bound to + and +[Z] because that

key is at the bottom left on a Mac keyboard — Windows users may want to change this to +

and a)-[1)


http://word.mvps.org/faqs/general/SaveViewAndZoom.htm
http://word.mvps.org/faqs/general/SaveViewAndZoom.htm
http://office.microsoft.com/en-gb/mac-word-help/word-keyboard-shortcuts-HA102929541.aspx
http://office.microsoft.com/en-gb/mac-word-help/word-keyboard-shortcuts-HA102929541.aspx
http://support.microsoft.com/kb/290938
http://support.microsoft.com/kb/123302
http://office-watch.com/t/n.aspx?a=1552
http://office-watch.com/t/n.aspx?a=1552
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Action Keyboard Shortcut
V. Ctrl+ (Grave) +
X Ctrl+~ (shift + Grave) (ctrl)+[ ~ ]
CodeBlock Ctrl+Alt+K ctrl]+[ <] +
CodeRun Ctrl+Alt+T ctrl ]+ <] +
MarkingBlock Ctrl+Alt+B ++
MarkingCodeBlock  Shift+Ctrl+Alt+B (0 )+[ert)+[<])+[ 8]
MarkingRun Ctrl+Alt+R ++@
MarkingCodeRun  Shift+Ctrl+Alt+R (8])+[ar)+(=)+(R]
MarkingStrikeOut  Ctrl+Alt+S ctrl ]+ <] +
Normal Ctrl+Alt+N ctrl]+[ <] +@
Default Inline Ctrl+Alt+D ctri)+[ <]+ D ]
MarkingComment  Ctrl+Alt+M + +@
MonitorRun Ctrl+Alt+Z (ctr)+(<]+(R]
MonitorBlock Ctrl+Alt+X (ctrl]+[ <] +
MonitorComment  Shift+Ctrl+Alt+M (0])+(ar)+(=])+(M])
T Ctrl+Alt+P arl]+(<]+[P]
- Ctrl+Alt+Left (ctrl)+[<]+[ ]
1 Ctrl+Alt+Up Arrow (ar]+[~=]+[1])
- Ctrl+Alt+Right ctrl)+[~]+(=]
! Ctrl+Alt+Down Arrow ctrl]+ <] +
= Shift+Ctrl+Alt+Right (T )+[er)+[<])+[=)
= Shift+Ctrl+Alt+Up Arrow @+ + +
v Shift+Ctrl+Alt+A ()+[ar)+[=)+(a]
3 Shift+Ctrl+Alt+E (0 )+[err)+[<]+[E])
€ Shift+Ctrl+Alt+l (8])+[an)+(=)+(1]
A Ctrl+Alt+A ctrl ]+ <] +
% Ctrl+Alt+O ctrl)+(~]+[0]
N Ctrl+Alt+ (arl]+[<]+[ 1]
U Ctrl+Alt+U ctrl)+(~]+[ U]
Copy & Paste Keyboard Shortcuts Mac Win
Copy Cmd+C (32)+c] curl)+[ ]
Cut Cmd+X (%8])+x]
Paste Cmd+V + +
Paste Special. .. Ctrl+Cmd+V ++ ++

Paste and Match Formatting

Shift+Alt+Cmd+V

none

Copy as RTF (TextMate)

Ctrl+Alt+Cmd+R

[ctrt)+(=)+(38)+(»]

n/a

Copy Format
Paste Format

Shift+Cmd+C
Shift+Cmd+V

T

ﬂ
—
=
+

O[3 )+ <]
RREIRE

Select column +[1])[1),=)[(=)

Shift+Cmd+F8

3 EE
+
(@)
~
=i
+
=]

(7]
Exit extended mode Cmd-+. +E] Esc
ResetChar Shift+Cmd+Z ++ +|Space
ResetPara Alt+Cmd+Q ~]J+(5¢)+(q] crl)+[ Q]
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4 Font Recommendations

Here are the issues for sharing documents with some maths fonts:
1. There are not many fonts that have all the required maths symbols.
2. There are not many combinations of fonts for text that work well (look right) with maths fonts.

3. Of the fonts fonts that satisfy the above two points, there are even fewer that are guaranteed to be
available in all versions of Word and all platforms.

Here are my suggestions for fonts to use:

Arial Unicode MS — available on just about all likely combinations on Word version and platform and
has all the required maths symbols. However it isn’t my choice for ease of reading on screen (it is a
bit cramped).

Lucida Sans Unicode — available on most Windows versions of Word and on Mac versions from 2008
(but not 2004 unless installed from elsewhere). This has all the required maths symbols but does
not have the Dingbat tick ¢ (Unicode U+2713 CHECK MARK) and cross X) (Unicode U+2717 BALLOT
X) — however | use the glyphs from Arial Unicode MS for just those two. Lucida has the advantage
of having a family of fonts that work together and being originally designed to be clear for reading
on low resolution devices such as computer screens (till we all get retina screens, anyway). Lucida
Sans Unicode is the M269 recommended font.

In the past, | have used the Wingdings ticks (252) and crosses (251) (Unicode Private Area char-
acters U+FOFC and U+FOFB, in Wingdings 2 they are characters 80, Unicode U+F050 and 79, Uni-
code U+F04F) but this is probably not a good thing — see http://www.alanwood.net/demos/
wingdings.html

DejaVu fonts — DejaVu fonts are available for all platforms from http://dejavu-fonts.org and have
most of the mathematical operators as well as fonts suitable for the text. However you would have
to persuade the recipient of your document to install them as well.

Some fonts can be embedded but not all versions of Word provide an interface to do the embedding.

Cambria and Cambria Math are available in Word 2007, 2010 and 2011 for Mac and are the default fonts
— see a description of them in Three Typefaces for Mathematics at http://www.typeculture.com/
academic_resource/articles_essays/ and navigate to the article.

If you use the Equation Tools then Cambria Math is the only font you can currently use. This leads
to a subtle problem if you are saving your document in Word 97-2004 format: all the maths is saved
as bit maps and the file can become huge. The author of the Word Equation Tools has a series of
articles on maths in Word at http://blogs.msdn.com/b/murrays/archive/2012/01/09/math-
in-office-T1inks.aspx

5 Font Substitution & Tools

The screen snap from an MS Word document viewed using MS Word 2004 for Mac in figure 4 shows some
missing glyphs with a box O symbol.

Word does font substitution if the document has fonts your version of Word and platform do not have —
unfortunately, it may substitute a font which does not have a glyph for a particular character — this is very
common when the character is from the maths symbols. You can find which fonts have been substituted
for missing fonts:

Word 2004, 2008 and 2011 for Mac {Word>> Preferences. .. >> Compatibility. . . } and click on [Font Substitution. . ]

Word 2010 —- From the File tab, click Options then click Advanced, scroll to the Show Document Content
options and click Font Substitution. . .

Word 2007 — Click the Microsoft Office Button and then Options and continue as Word 2010
You can also run the Compatibility Checker to see if there are any other issues:

Word 2007 — click the Microsoft Office Button and then Prepare and click Run Compatibility Checker


http://www.alanwood.net/demos/wingdings.html
http://www.alanwood.net/demos/wingdings.html
http://dejavu-fonts.org
http://www.typeculture.com/academic_resource/articles_essays/
http://www.typeculture.com/academic_resource/articles_essays/
http://blogs.msdn.com/b/murrays/archive/2012/01/09/math-in-office-links.aspx
http://blogs.msdn.com/b/murrays/archive/2012/01/09/math-in-office-links.aspx
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Question 2

(2) A ={n[dInethe character ACSII code n is a capital letter}

(i  'FOAas'F [ Int. 'F is a character.

iy A as'? [int. '?is a character.

(iiiy 70 I A, it is the ACSII code for 'F which is 2 capital letter.

(iv) 50 [ Aasit is the ASCII code for *2', which is not 2 capital
letter.

(v) "80"[JAas"80" []Ine. "80" is a sequence.

Figure 4: MS Word 2004 Missing Fonts

Word 2010 — from the File tab, click the Info tab and the Check for Issues tool and click on Check
Compatibility

Word 2004 for Mac — from the menu bar, click Tools > Compatibility Report. . .

Word 2008 for Mac — as Word 2004 but also you can click on the Toolbox icon in the Standard toolbar
and choose the Compatibility Report tab.

Word 2011 for Mac — from the menu bar, click View > Toolbox, Compatibility Report or click on the
Toolbox icon in the Standard toolbar and choose the Compatibility Report tab.

5.1 Font Tools

The tools we are looking for need to address the following questions — we wish to view the fonts rather
than have font creation tools:

1. Which glyphs are in this font ?
2. Which fonts have this particular glyph ?
3. Given a character displayed as not present (O0), what character is it ?

We would also like to know which versions of which package or operating system include particular fonts
— here are a couple of Web sites that have some information on that:

Microsoft typography > Fonts and Products > Products http://www.microsoft.com/typography/fonts/
product.aspx — which fonts are supplied with which product

Microsoft typography > Fonts and Products > Families http://www.microsoft.com/typography/fonts/
family.aspx

Microsoft Fonts with Office 2003 http://support.microsoft.com/kb/837463 (15 September 2012)

Microsoft Fonts with Office 2007 http://support.microsoft.com/kb/924623/en-us (15 September
2012)

Microsoft Fonts with Office 2010 http://support.microsoft.com/kb/2121313/en-us (15 Septem-
ber 2012)

Guide to Pre-Installed Fonts http://www.apaddedcell.com/web-fonts (15 September 2012)
Office for Mac Compatible Fonts http://blog.officeformac.com/power-tips-2/

Prepressure Fonts http://www.prepressure.com/fonts/basics/snow-Teopard-fonts/1ist, http:
//www.prepressure.com/fonts

The Alan Wood web site has descriptions of lots of tools for Unicode fonts — see http://alanwood.
net/unicode/index.html


http://www.microsoft.com/typography/fonts/product.aspx
http://www.microsoft.com/typography/fonts/product.aspx
http://www.microsoft.com/typography/fonts/family.aspx
http://www.microsoft.com/typography/fonts/family.aspx
http://support.microsoft.com/kb/837463
http://support.microsoft.com/kb/924623/en-us
http://support.microsoft.com/kb/2121313/en-us
http://www.apaddedcell.com/web-fonts
http://blog.officeformac.com/power-tips-2/
http://www.prepressure.com/fonts/basics/snow-leopard-fonts/list
http://www.prepressure.com/fonts
http://www.prepressure.com/fonts
http://alanwood.net/unicode/index.html
http://alanwood.net/unicode/index.html
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UnicodeChecker — from http://earthlingsoft.net/UnicodeChecker/index.html.en — donation
ware Mac, runs on Lion. This will answers questions 2 and 3 on an Apple Mac — this is one of
the few tools that will identify the character with the missing glyph. To do this, copy the missing
character (by copying the O character from MS Word) and paste it into the UnicodeChecker character
area in the main window.

Unicode Font Info — from http://pixel.recoil.org/code/unicodefontinfo/index.htm]l — free.
Runs on Mac, Snow Leopard (but not yet on Lion or above). This will answer question 1 on an Apple
Mac

Font Book — comes with Mac OS X — answers question 1 but not as conveniently as Unicode Font Info

Character Viewer — comes with Mac OS X — find it from System Preferences > Language & Text > Input
Sources tab — put it on your menu bar by checking the Show input menu in menu bar

PopChar X & PopChar Win — from http://www.ergonis.com/products/, not free, runs on Mac and
Windows. Answers questions 1 and 2

Microsoft Font Properties Extension — The Microsoft web site http://www.microsoft.com/typography/
has lots of useful information (Krieger (2007, page 26) describes this). Font Properties Extension
can be downloaded from this site — this gives details of embedding permissions (amongst other
things). To get the dialog box, do a secondary click (right click, usually) on a font file in the Fonts
directory — accessible from the Control Panel or as C: \WINDOWS\Fonts

MS Word Insert Symbol Dialogue The MS Word Insert Symbol dialogue gives access to symbols in a
particular font. This dialogue is obtained as follows:

MS Word 2007, 2010 Ribbon — Insert tab — Symbol group — Symbol contextual tab — More Sym-
bols. ..

MS Word 2003 (& earlier) Menu bar — Insert — Symbol. ..
MS Word 2004, 2011 for Mac (& earlier) Menu bar — Insert — Symbol. . .

Word Equation Tools — only available in versions of Word after 2004 — if you use this feature and then
convert to pre-2004 format, your equations will become bit maps and the files will become very
large. Use this when the OU accepts .docx format.

MS Windows Character Map Tool — MS Windows also has a Character Map tools to display all the char-
acters in a particular font — this enables characters to be inserted into a document as well as
finding which glyphs are in a font. It also gives the Alt + numeric keypad digits that may be
used to insert the character from the keyboard. (see Karp et al. (2002, page 117) and http:
//t1t.its.psu.edu/suggestions/international/accents/charmap.html)

This is obtained from Start — All Programs — Accessories — Character Mapper (sic) or Start —
Run... — charmap (Windows Vista and earlier, | have not checked later versions)

A Template Locations

The locations of folders for system and user templates and how you inspect or change the locations or
activate the templates depends on:

e Operating system: Windows XP, Windows Vista, Windows 7, and Mac OS X

e Version of Microsoft Office: Office 2003, Office 2007, Office 2010 (for Windows), Office 2004, Office
2008, Office 2011 (for Mac)

e The folder locations may be hidden and you may need to look up how to access certain folders or
make them visible.

This note was written using Office 2011 for Mac (10.7 Lion) and instructions for any other combination
should be checked — | have included some references | have used below:

Manage Templates in Office 2007 & 2010 http://support.microsoft.com/kb/924460
Location of Templates in Word 2003 and 2007 http://support.microsoft.com/kb/826867

Books see the References below — in particular Krieger (2007, 2011)


http://earthlingsoft.net/UnicodeChecker/index.html.en
http://pixel.recoil.org/code/unicodefontinfo/index.html
http://www.ergonis.com/products/
http://www.microsoft.com/typography/
C:\WINDOWS\Fonts
http://tlt.its.psu.edu/suggestions/international/accents/charmap.html
http://tlt.its.psu.edu/suggestions/international/accents/charmap.html
http://support.microsoft.com/kb/924460
http://support.microsoft.com/kb/826867
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A.1 Showing File Extensions

All of these notes assume you have made file extensions visible:

Mac OS X (versions 10.1 to 10.8, all versions to date) Go Finder > Preferences and in the Advanced
tab, check Show all filename extensions

Windows XP In Windows Explorer, go Tools > Folder Options and uncheck Hide extensions for known file
types

Windows Vista In Windows Explorer, go Organize > Folder and Search Options and then you get exactly
the same dialogue box as above in Windows XP

Windows 7 | think it is similar to Windows Vista (but cannot verify that)

A.2 Showing System and Other Hidden Folders

You may also need to view some hidden system or user library folders:

Mac OS X the are several ways to view the user library folder ~/Library — the ~ (tilde character) is
shorthand for the user folder.

e The easiest way is to install TinkerTool (free from http://www.bresink.com/osx/TinkerTool.
htm1) and in the Finder tab, check Show hidden and system files

e In Finder in the Go menu, press the Alt key and the Library folder appears as part of the menu
of destinations.

e To unhide just ~/Library, in Terminal say:

‘ chflags nohidden ~/Library

e To unhide all folders, in Terminal say:

‘ defaults write com.apple.finder AppleShowAl1Files -bool true

Windows get to the Folder Options dialogue box (as above for file extensions) and do the right thing. (it
should just be checking or unchecking some box)

A.3 Template Locations

Word templates can be stored anywhere you like but Word pays more attention to some locations:

User Templates — these can be loaded as global templates (or add-ins) or attached as document tem-
plates (building on Normal.dotm)

Windows XP C:\Documents and Settings\user name\Application Data\Microsoft\Templates
Windows Vista and Windows 7 C:\Users\user name\AppData\Roaming\Microsoft\Templates
Mac OS X ~/Library/Application Support/Microsoft/Office/User Templates/My Templates

User Startup Folder Word will load templates on startup from this folder — only use this folder if you
want the M269 toolbar for every Word session. There are system wide startup folders but you
probably shouldn’t be using those for individual users. Below | have used the environment variable
APPDATA instead of typing everything in full — it expands to the paths in the user templates above.

Windows XP %APPDATA%\Microsoft\Word\STARTUP
Windows Vista and Windows 7 %APPDATA%\Microsoft\Word\STARTUP
Mac OS X no default but can be set — see below.

Inspecting and Changing Template Locations

Word 2003 Go Tools menu > Options. On the File Locations tab, click User Templates and then click
Modify


~/Library
~
http://www.bresink.com/osx/TinkerTool.html
http://www.bresink.com/osx/TinkerTool.html
~/Library
~/Library/Application Support/Microsoft/Office/User Templates/My Templates
APPDATA
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Word 2007 Click on the Microsoft Office Button, then click Word Options, in the Advanced tab, click
File Locations. In the File Locations dialogue box, select User templates and then click modify.

Word 2010 From the File menu click Options, then follow the instructions for Word 2007

Office 2004, 2008, and 2011 for Mac In the Word menu, select Preferences > File Locations and
see figure 5

File Locations

(<] [iw] Q

Back/Forward  Show All Search Word Preferences

File locations

:\ File types 4 Location
Documents

Clipart pictures

User templates
Workgroup templates
AutoRecover files
Tools

Startup Macintosh HD:Users:molyne...soft User Data:WordStartup:

Modify...

Description of preference

File types

Lists the default storage location and search path for documents, templates, and other items
you create or use in Word. Click the item you want to change, and then click Modify to set a new
default location.

Cancel oK

Figure 5: Word 2011 File Locations dialog box

A.4 Loading and Attaching Templates

The differences between attached templates (or document templates) and global templates (or add-ins)
is described in http://msdn.microsoft.com/en-us/library/aal41685(v=office.10).aspx — you
probably only want to use my templates as global templates but unfortunately this means that certain
features of my templates would have to be copied to your NormaTl.dotm (this includes the marking custom
styles)

Word 2003 go Tools > Templates and Add-Ins. ..

Word 2007 click the Microsoft Office Button, then click Word Options, click Add-Ins, in the Manage list
select Word Add-Ins and then click Go. Click the Templates tab, under Global templates and add-ins
select the template you wish to add or remove.

Word 2010 From the File menu click Options, then follow the instructions for Word 2007 (I haven’t
checked this)

Office 2004, 2008, and 2011 for Mac go Tools > Templates and Add-Ins. .. and see figure 6


http://msdn.microsoft.com/en-us/library/aa141685(v=office.10).aspx
Normal.dotm
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Templates and Add-ins

Document template

[Normal.dotm N Attach...

(] Automatically update document styles

Global templates and add-ins

Checked items are currently loaded.

[V MathType Commands.dot Add...
wordcmds.dot

| wordTestMacros.dotm Remove
£ m263MolyneuxWo...plate2012AX.dotx

Full path:

Macintosh
HD:Users:molyneux:MyData:Documents:Subjects:WordProc:M
SWord:WordTemplates:M263WordTemplates:m263MolyneuxW

Description:
Loading a template makes it available as a global template

Organizer... | | Cancel | [ OK |

Figure 6: Word 2011 Templates and Add-ins dialog box
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B Custom Marking Styles

The templates contain several custom styles — here are the Microsoft Word descriptions of the main ones:

CodeBlock Font: (Default) Lucida Sans Typewriter, Pattern: Clear (Gray-5%), Style: Quick Style, Based on:
Normal

CodeRun Font: Lucida Sans Typewriter, Border:: (No border), Pattern: Clear (Gray-5%), Style: Quick Style,
Priority: 2, Based on: Default Paragraph Font

MarkingBlock Font: (Default) Lucida Sans Unicode, Font color: Black, Border:Box : (Single solid line,
Auto, 0.5 pt Line width), Pattern: Clear (Light Yellow), Style: Quick Style, Based on: Normal

MarkingCodeBlock Font: Lucida Sans Typewriter, Font color: Black, Style: Quick Style, Based on: Mark-
ingBlock

MarkingRun Font: Lucida Sans Unicode, Font color: Black, Border:: (Single solid line, Auto, 0.5 pt Line
width), Pattern: Clear (Light Yellow), Style: Quick Style, Priority: 2, Based on: Default Paragraph Font

MarkingStrikeOut Strikethrough, Font color: Red, Not Double strikethrough, Style: Quick Style, Priority:
2, Based on: Default Paragraph Font

MarkingCodeRun Font: Lucida Sans Typewriter, Font color: Black, Border:: (Single solid line, Auto, 0.5
pt Line width), Pattern: Clear (Light Yellow), Style: Quick Style, Priority: 2, Based on: MarkingRun

The styles with names starting Marking are not available in the Stu template

The Styles Menu item MarkingComment (Opt+Ctrl+Shift+M) provides an initial comment on the marking
style to be placed at the start of the TMA — it is in the MarkingBlock style.

The defaults are:

Normal Font: (Default) + Theme Body, 12 pt, Left, Line spacing: single, Widow/Orphan control, Style:
Quick Style

Default font Cambria (Body)

To change the default font, paragraph settings and document layout, go Format and then Font.. ., Para-
graph. .. or Document. ..

There is also a Monitor’s version of the template M269MolyneuxWordTemplate2013Mon.dotx which has
the following additions:

Style MonitorBlock Font color: Dark Red, Border:Box : (Single solid line, Dark Red, 0.5 pt Line width),
Pattern: Clear (Light Turquoise), Style: Quick Style, Based on: MarkingBlock

Style MonitorRun Font:Lucida Sans Unicode, Font color: Dark Red, Border:: (Single solid line, Dark Red,
0.5 pt Line width), Pattern: Clear (Light Turquoise), Style: Quick Style, Priority: 2, Based on: Mark-
ingRun

Style MonitorTitle Font: Lucida Sans Unicode, 12 pt, Bold, Style: Quick Style, Priority: 2, Based on Strong

Autotext mxmonitor: (Shift+Opt+Ctrl+M) Paragraph in style MonitorBlock with words Monitor’s Com-
ments: in style MonitorTitle and two line breaks.

C Word Symbol Table & Examples

The following two pages include the PDF of a Word document illustrating the symbols and marking styles
— I have not included examples of the CodeBlock and CodeRun styles since they are similar to the marking
styles but have a grey background.

The table of symbols includes a description of use in M269, the symbol (in Lucida Sans Unicode), the
Unicode name and code point (or character code, in hexadecimal), the XML entity and the BTgX markup
for the symbol (this document was written in BTgX which, for structured documents, is often easier than
Word, at least for me)

The not a functional dependency symbol 4 is a bit different since there is no Unicode character for that
— in Word this uses a field code to overstrike two characters — see section E.3 for the detail.
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M269 Symbols

- X TOOEATT 1T -]l => o w
Vigegll —v/ooAVANU

TE=<>2CC o Ll0O

Description Symbol Unicode Hex | Unicode Name XML Entity LaTeX

Not - U+00AC NOT SIGN &not; \heg

Plus Minus + U+00B1 PLUS-MINUS SIGN &plusmn; \pm

Multiplication X Uu+00D7 MULTIPLICATION &times; \times
SIGN

Division + U+00F7 DIVISION SIGN &divide; \div

Capital Theta o U+0398 GREEK CAPITAL &Theta; \Theta
LETTER THETA

Epsilon € U+03B5 GREEK SMALL &epsilon; \epsilon
LETTER EPSILON

Lambda A U+03BB GREEK SMALL &lambda; \lambda
LETTER LAMDA

Pi ™ U+03Co GREEK SMALL &pi; \pi
LETTER PI

Assignment - U+2190 LEFTWARDS ARROW | &larr; \leftarrow

Function type - U+2192 RIGHTWARDS &rarr; \rightarrow

operator ARROW

Implication = U+21D2 RIGHTWARDS &rArr; \Rightarrow
DOUBLE ARROW

If and only if = U+21D4 LEFT RIGHT &hArr; \Leftrightarrow
DOUBLE ARROW

Functional s U+21DD RIGHTWARDS &#x21DD; \leadsto

dependence SQUIGGLE ARROW

Universal A U+2200 FOR ALL &forall; \forall

quantifier

Existential 3 U+2203 THERE EXISTS &exist; \exists

quantifier

Empty set %) U+2205 EMPTY SET &empty; \emptyset

Element of € U+2208 ELEMENT OF &isin; \in

Not an element & U+2209 NOT AN ELEMENT &notin; \notin

of OF

Disjoint union 1 U+2210 N-ARY &#x2210; \amalg
COPRODUCT

Set difference - U+2212 MINUS SIGN &minus; $-%
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Description Symbol Unicode Hex | Unicode Name XML Entity LaTeX
Square root NG U+221A SQUARE ROOT &radic; \surd
Infinity 0 U+221E INFINITY &infin; \infty
And A U+2227 LOGICAL AND &and; \wedge
Or \Y U+2228 LOGICAL OR &or; \vee
Set intersection N U+2229 INTERSECTION &cap; \cap
Set union U U+222A UNION &cup; \cup
Therefore U+2234 THEREFORE &there4; \therefore
Not equal +* U+2260 NOT EQUAL TO &ne; \not=
Equivalence = U+2261 IDENTICAL TO &equiv; \equiv
Less then or < U+2264 LESS-THAN OR &le; \le
equal EQUAL TO
Greater than or > U+2265 GREATER-THAN OR | &ge; \ge
equal EQUAL TO
Proper subset C U+2282 SUBSET OF &sub; \subset
Subset c U+2286 SUBSET OF OR &sube; \subseteq

EQUAL TO
Concatenation ) U+2295 CIRCLED PLUS &oplus; \oplus
Undefined 1 U+22A5 UP TACK &perp; \bot
Space O U+25A1 WHITE SQUARE &#x25AT1; \Box
Not a Functional | \not\leadsto
Dependency

Example tick v/

Example cross X

Example marking block

Start text example marking run text

end text

function SUMSTACK(s) {
// Example marking code block
if (SIZE(s) == 0) then {

return O

}

else {

return PEEK(s) + SUMSTACK(POP(s))

}
}
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D Marking Points

New Lines & Paragraphs — in a code block, use new lines (Shift + Return) and only use new paragraph
(Return) at the end.

Copying & Pasting when marking can lead to all sorts of odd formatting depending on how the origin
and destination are formatted — here is what | probably should do when copying from a solution
document (third party, source) into a document being marked (also third party, target)

1. Copy the (possibly styled and formatted) text (and possibly other objects) from the source
document.

2. In the target document, create a marking style — MarkingBlock (Opt+Ctrl+B), MarkingRun
(Opt+Ctrl+R), MarkingCodeBlock (Opt+Ctrl+Shift+B) or MarkingCodeRun (Opt+Ctrl+Shift+R) —
which you choose will depend on the particular comment.

3. At the insertion point, get the Paste Special dialog by going Ctrl+Cmd+V or right-click and
choose Paste Special... — see figure 7

Paste Special

Source: Microsoft Word Document

Macintosh HD:Users:molyneux:MyData:Documents:OU:M263:Block4...

(*) Paste: As:

() Paste link: Microsoft Word Document Object
Formatted Text (R

Display as icon Unformatted Text

Picture
Styled Text
HTML Format
PDF

Result

Inserts the contents of the Clipboard as text with font and

.{é table formatting.

Cancel | OK

Figure 7: Word 2011 Paste Special dialog box

4. From the Paste Special dialog choose Formatted Text (RTF) and click OK (or click Return). In the
result click on the Paste Options button at the end of the paste and see something like figure 8

function COMPARE (arr,s) T
{ a
return AT (1l,arr) == PEEK(s) T

} T
-

@  Use Destination Styles

Keep Source Formatting

O Match Destination Formatting

O Keep Text Only

Figure 8: Word 2011 Paste Options dialog box 01

This is not quite what you want since the default is Use Destination Styles.
5. Choose Match Destination Formatting and see something like figure 9

6. You can abbreviate this process if you know you want to always match destination formatting
by doing steps 1 and 2 and then going Edit > Paste and Match Formatting (Alt+Shift+Cmd+V)
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function COMPARE(arr,s) -
{-
return AT(1l,arr) == PEEK(s) -

~ () Keep Source Formatting
() | Use Destination Styles
@  Match Destination Formatting
8} Keep Text Only

Figure 9: Word 2011 Paste Options dialog box 02

Show all non-printing characters — in figure 9 you can see some (blue) new line characters — and the
(pilcrow) end of paragraph marker — | often find it easier to see what is going on if | use the pilcrow
icon in the standard toolbar to show all non-printing characters. (this is where you do it in Word
2011 there will be something similar in other versions of Word)

Configure AutoCorrect and Spelling and Grammar — | make the following changes:

e Uncheck Capitalize first letter of sentences — avoids unwanted capitals in code blocks.

e Uncheck Capitalize first letter of table cells — similar reason to above

e Uncheck Replace text as you type — otherwise (c), (r) and (tm) always turn into ©, ®, ™ and <--

turns into <

e In Spelling and Grammar, uncheck Check grammar as you type — to avoid distraction in code

blocks.

Find AutoCorrect Options by

Word 2011 for Mac Word menu > Preferences... > AutoCorrect dialog > AutoCorrect tab

Word 2010 for Windows File tab > Options > Proofing section > AutoCorrect Options button
Word 2007 for Windows click the Microsoft Office Button, then click Word Options then as Word

2010

E Creating and Editing Autotext, Styles, Fields and Toolbars

TODO:

E.1 Autotext

TODO:

E.2 Styles

TODO:

E.3 Fields

TODO: Finish this by adding some screen snaps
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e In the various tables of symbols, the not a functional dependency symbol + is the odd one out —
there is no Unicode character for that (that | could find) so the templates have used the EQ (Equation)
field to overstrike the RIGHTWARDS SQUIGGLE ARROW U+21DD with a SOLIDUS U+002F — this was

done as follows:

1. In Word 2010 access the Field dialogue by going to the Insert tab on the ribbon, in the Text
group click Quick Parts and then click Field. In Word 2011 for Mac access the Field dialogue by
clicking the Insert menu and then Field. ..

2. In Word 2010 select the Eq field and in Properties select the \O for overwrite. In Word 2011
select the Eq field name and click on the Options... button to add \O()

The arguments for \O() should be ~ followed by a comma and then /

Right click and in the context menu select Toggle Field Codes

vl A~ W

Create an Autotext entry so that you can type (say) mxnotleadsto: to generate the new symbol.
6. The autotext entry can then be given a keystroke shortcut and added to the custom toolbar

e You can display all field codes by pressing Alt+F9. In Word 2010 Ctrl+F9 converts selected text to
a field (if correct) and F9 updates the field. In Word 2011 you can use Cmd+F9 to convert selected
text to a field but F9 triggers Exposé by default.

e Web sites with information on field codes include
Insert and format field codes in Word 2010 — Word — Office.com
Field codes in Word — Word — Office.com

Field codes: Eq (Equation) field — Word — Office.com

Insert or update a field code — mac word — Office.com

E.4 Toolbars

TODO:

F Reference Tables

TODO:

G Using Word Math Autocorrect

If you do not wish to install the Word templates, you can use Math Autocorrect to generate many of the
symbols:

Word 2007,2010 Go File > Options > Proofing > Autocorrect Options... > Math Autocorrect and check
Use Math AutoCorrect rules outside of math regions

Word 2011 for Mac Go Word menu > Preferences > Autocorrect in the Authoring and Proofing Tools
group > choose the Math Autocorrect tab and check Use Math AutoCorrect rules outside of math
regions

In either PC or Mac version of Word you can now type \exists and get 3 and many other symbols. The
markup is very similar (mainly identical) to BTEX — Murray Sargent’s MSDN blog has articles on this
at http://blogs.msdn.com/b/murrays/ — in particular see http://blogs.msdn.com/b/murrays/
archive/2012/01/09/math-in-office-1inks.aspx


http://office.microsoft.com/en-us/word-help/insert-and-format-field-codes-in-word-2010-HA101830917.aspx
http://office.microsoft.com/en-gb/word-help/field-codes-in-word-HA102110133.aspx
http://office.microsoft.com/en-us/word-help/field-codes-eq-equation-field-HP005186148.aspx
http://office.microsoft.com/en-us/mac-word-help/insert-or-update-a-field-code-HA102928637.aspx
http://blogs.msdn.com/b/murrays/
http://blogs.msdn.com/b/murrays/archive/2012/01/09/math-in-office-links.aspx
http://blogs.msdn.com/b/murrays/archive/2012/01/09/math-in-office-links.aspx
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H Issues & Future Work

Shortcut key in ScreenTips — only show if the template is attached (not global, except for Normal) —
this may of course be a mistake on my part — if you know a solution, let me know.

Style issues

e The light yellow background shading for marking blocks or runs works (for me) on screen but
only the black border is visible in print. An addition of a 5% background pattern is visible in
print with the yellow but may detract from readability of maths expressions — let me know
what you think.

e Opening an existing Word document requires the Automatically update document styles button
to be checked in the Templates and Add-ins dialog box — but read http://www.shaunakelly.
com/word/sharing/wilTmyformatchange.html and http://word.mvps.org/faqs/macrosvba/
UpdateStyles.htm

TODO: Items — various sections remain to be filled in from notes elsewhere — and there will be some
typos.

I Contact & Updates

Email — my preferred email address is molyneux@pobox.com — please send any bug reports or queries
to that address.

M269 Word Templates will be available at http://www.pmoTlyneux. co.uk/WordProc/MSWord/WordTemplates/
M269WordTemplates/ — if | update them | may change their names (unless it is just a bug fix)

This File will be available at http://www.pmoTlyneux.co.uk/WordProc/MSWord/WordTemplates/WordtempTlatesNc
M269WordTemplatesNotes/ — the name of the original file is m269WordMarking2012.pdf — any
updates will either have the same name (small updates) or a similar name (larger updates)

J Versions & Updates

15 September 2012 version 1 for OU module M263
7 October 2012 version 1.01

e added style MarkingStrikeOut with changes to making menu (figure 3 in section 3), Keyboard
Shortcut table (section 3.2), description of custom marking styles (section B)

e Added autotext mxmarking: (Opt+Ctrl+Shift+M) to provide initial marking comment and added
that to the Keyboard Shortcut table (section 3.2).

5 October 2013 version 2 for OU module M269
7 October 2013 version 2.1

e Corrected installation instructions for Word 2010 — have to use the Building Blocks Organizer
as well as the Organizer

e Added material in Appendix E
21 December 2013 version 2.2
e Added keystroke shortcuts for Reset Char and Reset Para
15 January 2014 version 3
e Changed Tick and Cross from Ctrl+S and Ctrl+F to Ctrl+grave and Ctrl+tilde

e Added health warning about keyboard shortcuts


http://www.shaunakelly.com/word/sharing/willmyformatchange.html
http://www.shaunakelly.com/word/sharing/willmyformatchange.html
http://word.mvps.org/faqs/macrosvba/UpdateStyles.htm
http://word.mvps.org/faqs/macrosvba/UpdateStyles.htm
molyneux@pobox.com
http://www.pmolyneux.co.uk/WordProc/MSWord/WordTemplates/M269WordTemplates/
http://www.pmolyneux.co.uk/WordProc/MSWord/WordTemplates/M269WordTemplates/
http://www.pmolyneux.co.uk/WordProc/MSWord/WordTemplates/WordtemplatesNotes/M269WordTemplatesNotes/
http://www.pmolyneux.co.uk/WordProc/MSWord/WordTemplates/WordtemplatesNotes/M269WordTemplatesNotes/
m269WordMarking2012.pdf
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